Back to overview
Degraded

Email Connectivity

Apr 27, 2026 at 10:31am UTC
Affected services
Heart Internet - Shared Mail

Resolved
Apr 27, 2026 at 12:06pm UTC

Update - The issue has now been resolved, and everything should be back to normal. We wiill continue to monitor things from our side.

The incident was caused by a sudden spike in traffic to the server, which triggered our DDoS protection and traffic filtering systems.

Created
Apr 27, 2026 at 10:31am UTC

We are aware of some intermittent connecticity to imap.extendcp.co.uk. Our platform team are working on this as a priority.