Back to overview

Connectivity

Mar 23, 2026 at 11:08am UTC
Affected services
Heart Internet - Services

Resolved
Mar 23, 2026 at 11:08am UTC

We are aware of some connectivity issues across a small number of servers our SRE team are working on this as a top priority, we will update again once further information is available.

Update 11.13 - the issue has now been resolved and services are returning to normal.