Back to overview
Degraded

This is a Test Status

Mar 09 at 01:20pm GMT
Affected services
Heart Internet - DNS

Resolved
Mar 09 at 02:00pm GMT

Test concluded.

Created
Mar 09 at 01:20pm GMT

Nothing is wrong, please ignore this.