Back to overview
SMTP Connections
May 23 at 11:18am BST
Affected services
Heart Internet - Shared Mail
Resolved
May 23 at 11:18am BST
We are aware of reports of some intermittent SMTP connectivity, the team are looking into this as a priority.
Update - We are aware of the impact on email deliverability for inbound email.
Update - This is now resolved
Affected services
Heart Internet - Shared Mail