Support Chat Availability
Resolved
Jan 09 at 01:40pm GMT
Live Chat Unavailable: System Upgrades in Progress
We are currently conducting upgrades to our systems to serve you better. As a result, Live Chat support is temporarily unavailable.
Ticket support remains available 24/7, and our team is committed to responding to every ticket as quickly as possible.
Thank you for your understanding and patience during this time.
Affected services
Heart Internet - Services
Created
Dec 23 at 05:21pm GMT
Due to reduced staffing across the holiday period, our support chat will be closed from Christmas Eve through to 3rd January. Don’t worry though! Our hardworking support team will still be available to help via tickets throughout the holidays. If you have any questions or need assistance, rest assured they won’t go unanswered.
Affected services
Heart Internet - Services