Shared Mail abnormal server behaviour
Incident Report for Heart Internet
Resolved
The underlying issue has been resolved by our teams and email functionality has returned to normal levels.

If you are experiencing any issues with email connectivity or deliverability please raise a ticket to our support team.
Posted May 26, 2023 - 09:53 BST
Identified
We've identified the underlying issue on Shared Mail platform, new emails should be delivered immediately. Unfortunately, emails that entered the processing queue today (24th May) may experience a delay in delivery, approximately within the next 6-8 hours of this update.
Heart Internet understands the importance of email to customers and would like to apologise for any inconvenience this may cause.
Posted May 24, 2023 - 18:50 BST
Investigating
We are investigating an issue affecting mail activity on our Shared Mail platform. We will provide further updates when possible.
Posted May 24, 2023 - 14:47 BST
This incident affected: Mailservers.