"Business Email" Mail Boxes - Webmail
Incident Report for Heart Internet
Resolved
This has now been resolved.
Posted Feb 21, 2024 - 12:32 GMT
Identified
We're aware of an issue with logins to webmail to "Business Email" mail boxes . We're working on it. Thanks for your patience.
Posted Feb 15, 2024 - 08:09 GMT