Live chat support availability
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Dec 23, 2020 - 08:10 GMT
Investigating
Our live chat support service is currently unavailable. Telephone and ticket support are available as normal.

We apologise for any inconvenience caused.
Posted Dec 22, 2020 - 13:50 GMT
This incident affected: Control Panels.