Domain credit manual renewals
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Dec 14, 2022 - 16:27 GMT
Investigating
We are currently seeing some issues with manually renewing domains using domain credits. We are investigating this but for any urgent renewals please contact support for assistance.
Posted Dec 13, 2022 - 17:07 GMT