Live chat closed
Incident Report for Heart Internet
Update
Apologies - chat is temporarily closed due to a technical issue, it will be opened as soon as matters are resolved
Posted Apr 04, 2024 - 10:19 BST
Investigating
Due to system upgrades taking longer than expected, staff access to some support systems is still restricted, so there will be no livechat until further notice. We are continuing to try to resolve the problem and will update with any further details, as soon as we have them.
Posted Apr 03, 2024 - 08:53 BST