Premium Hosting
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted May 25, 2020 - 03:38 BST
Investigating
We're aware of an issue with Premium Hosting. We're working on it. Thanks for your patience.
Posted May 25, 2020 - 01:26 BST
This incident affected: Premium Hosting.