Delays to checkout process
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jan 31, 2024 - 14:26 GMT
Investigating
We are aware of an issue causing delays to the checkout process and are investigating this further. If you have attempted any payments please do not retry these at this time.
Posted Jan 30, 2024 - 14:11 GMT
This incident affected: Control Panels.