Update on email server connection issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 16:59 GMT
Identified
On November 30th, some customer email accounts mistakenly received emails meant for others. In rare cases, some customers were able to view unrelated emails and folders. In addition, some emails may have been unintentionally deleted or lost.

We have corrected the technical issue that caused this situation. If, however, you can access your mailbox using our webmail service, but your IMAP mail client isn't connecting correctly to your mailbox, you will need to re-add, you can follow these instructions: https://www.heartinternet.uk/support/article/how-do-i-set-up-a-mailbox-using-imap-on-my-device-or-mail-client.html

We apologise for any inconvenience this may have caused.
Posted Dec 01, 2023 - 17:55 GMT
This incident affected: Mailservers.