Support phonelines
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jun 07, 2022 - 10:37 BST
Investigating
The Heart Internet Phone Support lines will be under maintenance from 1PM today until 9am on Thursday 2nd June

Should you require support during this time, please either start a chat or open a ticket.

We apologise for the inconvenience caused by this.
Posted May 31, 2022 - 12:36 BST