Hosting and server dashboard issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jan 10, 2024 - 15:28 GMT
Investigating
We are seeing some issues with the dashboard for multiple hosting and server products at https://host.secureserver.net/ not loading correctly. Servers remain functional but control panel access may be limited.

This issue is currently being investigated.
Posted Jan 10, 2024 - 15:06 GMT
This incident affected: Control Panels.