mail61 connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted May 09, 2020 - 13:30 BST
Investigating
We are currently seeing mail connectivity issues on server mail61, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted May 09, 2020 - 12:49 BST
This incident affected: Mailservers.