Mailserver connectivity
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Aug 20, 2021 - 12:12 BST
Identified
The current issue appears to be affecting Sky broadband customers only who are currently facing issues when trying to access some websites.
Posted Aug 20, 2021 - 10:21 BST
Investigating
We are aware of an issue affecting some customers that is preventing them from making connections to mail servers. We are working to resolve this as soon as possible
Posted Aug 20, 2021 - 10:07 BST