Email Connectivity Issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 10:55 BST
Investigating
We're investigating reports that connections to mail servers are failing with repeated password prompts, or emails being sent are delayed.
Posted Jul 16, 2020 - 09:06 BST
This incident affected: Mailservers.