Payment processing
Incident Report for Heart Internet
Resolved
This has now been resolved.
Posted Jan 27, 2023 - 16:07 GMT
Investigating
We are currently investigating problems for some customers when attemtping to process payments and managing their account credit and payment methods.
Posted Jan 27, 2023 - 15:43 GMT
This incident affected: Control Panels.