Webmail connectivity issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 11:27 BST
Monitoring
A fix has been put into place however connectivity to the webmail service is delayed, customers may experience longer loading times when logging in.
Posted Jun 03, 2020 - 15:19 BST
Investigating
We are currently seeing connectivity issues on our webmail servers, customers are experiencing internal server errors and 500 errors when trying to access their emails, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted Jun 03, 2020 - 13:20 BST