Shared Mail abnormal server behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Apr 24, 2023 - 11:02 BST
Investigating
We're aware of an issue affecting mail activity on the Shared Mail platform. This is being investigated, additional information will be provided when available.

We apologise for any inconvenience caused.
Posted Apr 20, 2023 - 14:12 BST
This incident affected: Mailservers.