Direct Debit payments
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted May 23, 2023 - 16:36 BST
Update
We are continuing to work on a fix for this issue.
Posted Nov 29, 2022 - 12:11 GMT
Identified
Progress is being made and payments taken however there may be a small delay with invoices being marked as paid.
Posted Nov 29, 2022 - 12:11 GMT
Update
We are continuing to investigate this issue.
Posted Nov 03, 2022 - 11:47 GMT
Investigating
We are currently experiencing issues taking Direct Debit payments as we carry out essential work on our payment system.

Please pay attention and ensure your contacts are up to date, as we will email you in case you are affected by this issue. You can also manually renew at any time by accessing your Client Area and via using a credit or debit card.

If you have recently renewed your package via Direct Debit, please check your Client Area to ensure your package has renewed successfully.
Please accept our apologies. We will keep you updated on the situation and if further actions are needed.
Posted Nov 02, 2022 - 16:45 GMT
This incident affected: Control Panels.