Registry connectivity
Incident Report for Heart Internet
Resolved
This has now been resolved.
Posted Oct 18, 2017 - 20:52 BST
Investigating
We are aware of an issue relating to registry connectivity. Domain-related services will be intermittent or failing.

Additionally, premium hosting services will also be intermittent, but websites will continue to be served.
Posted Oct 18, 2017 - 13:18 BST