Mail Server SSL Warnings for Apple Users
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. May 10, 2019 - 16:35 BST
Identified
As of Wednesday, those who use a mail client on their Apple devices to connect to our shared mail services may be encountering an error regarding an SSL certificate mismatch.

To fix this, please see our Knowledgebase Article:
https://www.heartinternet.uk/support/article/ssl-warning-on-apple-devices-when-connecting-to-mail-server.html
Posted 5 months ago. Mar 21, 2019 - 10:33 GMT
This incident affected: Mailservers.