Telephone System
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jan 16, 2017 - 17:29 GMT
Investigating
We are currently having issues with our inbound telephone lines to our Sales Team and Account Support Line. Our engineers are working on this issue and we expect to have our lines back to normal operation shortly.
Posted Jan 16, 2017 - 16:44 GMT