Connections to Heart Internet Website
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 9 days ago. Feb 11, 2019 - 17:09 GMT
Investigating
We are currently experiencing issues with connections to the Heart Internet website - www.heartinternet.uk. Our teams are looking into this and hope to have the matter resolved as soon as possible.
Posted 9 days ago. Feb 11, 2019 - 16:10 GMT