Exchange Mailboxes
Incident Report for Heart Internet
Resolved
A small number of Exchange mailboxes were affected by the issue and has been promptly resolved. Thank you for your patience.
Posted 4 months ago. Jul 13, 2018 - 10:27 BST
Identified
We have currently identified a problem affecting some of our exchange mailboxes. our system administrators are currently investigating this and we hope to have this resolved as soon as possible.
Posted 4 months ago. Jul 13, 2018 - 09:22 BST