E-Mail Delivery to BT and Yahoo
Incident Report for Heart Internet
Resolved
This has been resolved.
Posted Jan 19, 2017 - 14:42 GMT
Update
- We are now seeing some failures as well as delays with Mail Delivery to BT and Yahoo addresses from messages sent from our network.

Our System Administrators are currently working on this and we will provide further updates here as we have them.

We apologise for the inconvenience caused as a result of this.
Posted Jan 06, 2017 - 09:31 GMT
Investigating
We are seeing some delays with Mail Delivery to BT and Yahoo addresses from messages sent from our network.

Our System Administrators are currently working on this and we will provide further updates here as we have them.

We apologise for the inconvenience caused as a result of this.
Posted Jan 05, 2017 - 11:16 GMT