SSL orders/renewals
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jan 14, 2017 - 17:36 GMT
Investigating
We are currently experiencing an issue with SSL installations following orders or renewals. This is effecting SSL's setup on our shared servers.

Our system administrators are investigating the cause.
Posted Jan 14, 2017 - 16:47 GMT