Customer Login Error
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 05, 2018 - 15:43 BST
Investigating
We are currently aware of a problem affecting our website, login page to be precise. We are investigating this had hope to have this resolved as soon as possible.
Posted 5 months ago. Jul 05, 2018 - 14:50 BST