Mail50 abnormal server behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 12 days ago. Oct 03, 2019 - 18:00 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 12 days ago. Oct 03, 2019 - 17:45 BST
Investigating
We are currently seeing abnormal behaviour on mail50, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted 12 days ago. Oct 03, 2019 - 16:46 BST