Mailbox Connectivity
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Mar 21, 2024 - 11:09 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2024 - 10:57 GMT
Investigating
We are currently investigating a problem with mailbox access that is affecting some customers.
Posted Mar 21, 2024 - 10:44 GMT
This incident affected: Mailservers.