Mail Server Connectivity Issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 20, 2019 - 12:21 GMT
Investigating
We're investigating reports of connectivity issues on our shared mail servers.

We'll provide updates as soon as possible.
Posted 3 months ago. Mar 20, 2019 - 11:55 GMT
This incident affected: Mailservers.