DNS management issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jun 19, 2022 - 17:59 BST
Investigating
We are seeing some issues with managing DNS for domains that are using our *.domaincontrol.com nameservers and it may not be possible to view or change DNS records for affected domains. This is currently being investigated.

Legacy Heart Internet nameservers and 3rd party external nameservers should not be affected.
Posted Jun 19, 2022 - 16:22 BST
This incident affected: DNS.