Payment processing delays
Incident Report for Heart Internet
Resolved
This has now been resolved. If you are continuing to experience any issues with processing payments please raise a ticket with our support team.
Posted Sep 14, 2023 - 15:48 BST
Investigating
We are currently seeing some delays for payments being taken and invoices being generated. We are investigating this further now. Please do not re-attempt any payments in the meantime.
Posted Sep 14, 2023 - 15:06 BST
This incident affected: Control Panels.