Live Chat Unavailable
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Nov 29, 2019 - 13:26 GMT
Identified
Our Live Chat service is currently unavailable. We apologise for any inconvenience caused.
Posted Nov 28, 2019 - 14:10 GMT