Live Chat Support
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Aug 19, 2022 - 10:35 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2022 - 09:12 BST
Identified
Currently our live chat support is not available at present. We are working on getting this back online as soon as possible and apologise for any inconvenience caused. For support you can open a ticket via your control panel.
Posted Aug 18, 2022 - 07:59 BST