Payment Processing Issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 17:41 BST
Monitoring
The issue with processing card payments has improved, and our teams are continuing to monitor the situation.
Posted Apr 07, 2021 - 15:26 BST
Investigating
We are aware that customers may experience issues processing card payments at the moment, and may be presented with the following message:

"Sorry, I didn't manage to bill your card. Maybe it has expired?"

Our teams are investigating this and hope to have the issue resolved shortly.
Posted Apr 07, 2021 - 09:41 BST
This incident affected: Control Panels.