Heart Internet website
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Mar 30, 2022 - 17:29 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2022 - 17:22 BST
Investigating
We are currently investigating a problem with some customers having problems accessing the Heart Internet website. Please bear with us, we are working on getting this resolved as soon as possible.
Posted Mar 30, 2022 - 17:18 BST