mail61
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 03:18 BST
Investigating
We're aware of an issue with shared hosting mail server "mail61". We're working on it. Thanks for your patience.
Posted Jun 02, 2020 - 02:02 BST
This incident affected: Mailservers.