SSL order issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 19:17 GMT
Investigating
We are currently seeing intermittent issues with processing SSL certificate orders and are investigating this.

We apologise for any inconvenience caused.
Posted Nov 13, 2020 - 16:05 GMT