cPanel and managed WordPress login issues
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 10:56 GMT
Investigating
We are currently seeing some issues logging into the control panels for cPanel hosting and Managed Wordpress and are investigating.
Posted Mar 19, 2021 - 08:56 GMT