Mail Platform abnormal behaviour
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Sep 24, 2019 - 15:20 BST
Identified
We are currently seeing abnormal behavior on the shared mail service, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted Sep 24, 2019 - 13:49 BST
This incident affected: Mailservers.