Abnormal server behavior
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted May 28, 2020 - 14:52 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2020 - 13:15 BST
Investigating
We are currently seeing abnormal behavior on a number of webservers/mailservers, customers are experiencing timeout errors when visiting their websites, we are investigating and hope to get this working as soon as possible.

We apologise for any inconvenience caused.
Posted May 28, 2020 - 12:42 BST