mail36
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 01:19 BST
Investigating
We're aware of an issue with shared hosting mail server "mail36". We're working on it. Thanks for your patience.
Posted Jun 01, 2020 - 00:44 BST
This incident affected: Mailservers.