Ordering new products and manual renewals
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 15:14 BST
Investigating
We are currently seeing some issues processing orders for new products and manual renewals. We are currently investigating this.
Posted Oct 06, 2022 - 13:16 BST