mail94
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 10:14 GMT
Investigating
We're aware of an issue with sending and receiving email on the mail server "mail94". We're working on it. Thanks for your patience.
Posted Feb 26, 2020 - 01:24 GMT
This incident affected: Mailservers.