Christmas Opening Hours
Incident Report for Heart Internet
Resolved
We are now back to our normal operating hours.
Posted Jan 04, 2022 - 11:47 GMT
Monitoring
Our support opening hours over the Christmas holidays will be as follows:

24th December - 08:00-17:00 GMT (Tickets, Phones, and Chat)
25th December - 08:00-17:00 GMT (Tickets)
26th December - 08:00-17:00 GMT (Tickets)
27th December - 08:00-17:00 GMT (Tickets, Phones, and Chat)
28th December - 08:00-17:00 GMT (Tickets, Phones, and Chat)
1st January - 08:00-17:00 GMT (Tickets, Phones, and Chat)

As always, we will have 24/7 monitoring for all of our services.

From all of us at Heart Internet, we wish you a Merry Christmas and a happy new year.
Posted Dec 23, 2021 - 12:26 GMT