Domain name transaction temporary issue
Incident Report for Heart Internet
Resolved
This incident has been resolved and we will continue to monitor.
Posted Aug 30, 2024 - 16:27 BST
Investigating
We are currently investigating a communication issue with our domain provider which is impacting a small number of domain transactions. Please bear with us as we continue to investigate.
Posted Aug 30, 2024 - 10:37 BST