mail61
Incident Report for Heart Internet
Resolved
This incident has been resolved.
Posted May 27, 2020 - 04:59 BST
Investigating
We're aware of an issue with shared hosting mail server "mail61". We're working on it. Thanks for your patience.
Posted May 27, 2020 - 03:40 BST
This incident affected: Mailservers.